e3d Titan Extruder

This is the place to show off your felix printer hacks and improvements.
Post Reply
3Diy
Posts: 11
Joined: Wed Apr 13, 2016 9:53 pm

e3d Titan Extruder

Post by 3Diy » Mon Dec 26, 2016 12:55 am

Hi,
I´m just wondering if anyone is using the Titan Extruder with his Felix Printer?
http://e3d-online.com/Titan-Extruder

I´m tempted to buy one but I dont know how easy it would be to install it as direct drive.

jjlink
Posts: 30
Joined: Thu Nov 27, 2014 4:45 pm
Location: California, USA

Post by jjlink » Mon Dec 26, 2016 4:47 pm

I would love to use the Titan extruder with the Felix 3.0 dual extruder; however someone would need to design a mount. Maybe modify one on them on thingiverse. I added the Titan to a DIY 3d printer and it works wonderfully. Also I would use the pancake extruder motor that Thomas Sanladerer suggested (It worked great on my DIY printer) https://www.youtube.com/watch?v=tiAQ9slUZ58&t=2s
Felix 3.0 with E3D Dual direct drive extruder conversion. (http://forum.felixprinters.com/viewtopic.php?f=9&t=1630)
Software: simplify3d

dwmartin805
Posts: 4
Joined: Tue Sep 16, 2014 3:43 pm

Post by dwmartin805 » Tue Jan 03, 2017 12:34 am

I've designed one for my 3.0 Dual with a e3D Chimera. I bought new pancake steppers to reduce the weight. I have a friend with access to a waterjet so I used an aluminum plate to mount the Titans. I tested it with a printed mount as well.

https://goo.gl/photos/KJsdxf6ncTMv9m6FA

User avatar
Kentxu
Posts: 20
Joined: Sat Jul 20, 2013 9:16 pm

Post by Kentxu » Mon Apr 09, 2018 12:00 pm

Just made this one:

https://www.thingiverse.com/make:475790

Working well.

Image
Last edited by Kentxu on Tue May 08, 2018 9:57 pm, edited 1 time in total.

MW_Paul
Posts: 1
Joined: Tue Mar 20, 2018 5:39 pm

Post by MW_Paul » Mon May 07, 2018 12:15 pm

I added a Titan Aero to my Felix 3D printer.
But I have an Issue, Hot-End temperature rises very slow.
The Firmware settings of E3D are done well.
I am using the rigth heating cartridge.
Please help, what could be the Issue.

Greetings,
Paul

User avatar
Kentxu
Posts: 20
Joined: Sat Jul 20, 2013 9:16 pm

Post by Kentxu » Tue May 08, 2018 9:38 pm

Hi Paul,
I updated the firmware to Repetier 0.929 and changed to EXT0_TEMPSENSOR_TYPE 8, and also the other settings in the V6 firmware guide:
https://e3d-online.dozuki.com/Guide/V6+ ... 24?lang=en
And also adjusted the E-steps-per-mm in the EEPROM by measuring the lenght of extruded filament:
https://e3d-online.dozuki.com/Guide/Tit ... 36?lang=en
But I guess you have done all that.

One other thing to check would be that you have a 12V heater (my Felix 2.0 is a 12V system). If it is a 24V heater on a 12V system then heating will be slow. Here's the resistance so you can check what you have got:
12v/30w: 5-6 ohms
12v/40w: 3-4 ohms
24v/30w: 19-24 ohms
24v/40w: 9-12 ohms

Hope this helps,
Ken

Post Reply