Slic3R is hanging when generating perimeters

Discussions about firmware/slicing software, tweaks and settings
Post Reply
Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Slic3R is hanging when generating perimeters

Post by Studiojohn » Fri Apr 11, 2014 9:27 am

I have created a fairly simple ships rudder shape. There doesn't seem to be a problem with the stl file and when loaded into repetier the object is manifold and seems to be OK. When generating the g-code the process is hanging on the command "generating perimeters". I have been using the felix for a couple of months now and printed vastly more complex shapes than this one. I have tried changing the layer thickness and the perimeter quantity without any luck. Has anyone any ideas? I have attached the stl file if you would care to try for yourself.
Attachments
Rudder 96th.stl
STL file of a simple rudder shape
(464.63 KiB) Downloaded 41 times

Dreide
Posts: 176
Joined: Sun Sep 29, 2013 12:32 am
Location: Lausanne, Switzerland

Post by Dreide » Fri Apr 11, 2014 11:29 am

Can you post the slicer configuration files?
Felix 2.0->3.0dual * Repetier (host+firmware) * KISSlicer Pro, Simplify3D * Cubify Design

Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Post by Studiojohn » Fri Apr 11, 2014 3:49 pm

Dreide

I will if you can tell me where to look to find them. I just use the printer and I'm not a techie.

Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Post by Studiojohn » Fri Apr 11, 2014 4:05 pm

Dreide

I found this ini file. Not sure if its the one you need or if there any others required

Hope this helps

Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Post by Studiojohn » Fri Apr 11, 2014 4:07 pm

Dreide

Won't let me upload an ini file.

Let me know precisely which files and how you would like them and I will try to oblige
Many thanks

Dreide
Posts: 176
Joined: Sun Sep 29, 2013 12:32 am
Location: Lausanne, Switzerland

Post by Dreide » Fri Apr 11, 2014 5:38 pm

Okay, "this ini file" is not that specific, but giving it a different extension might help to get it uploaded. After all, it is just a plain text file.
Felix 2.0->3.0dual * Repetier (host+firmware) * KISSlicer Pro, Simplify3D * Cubify Design

Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Post by Studiojohn » Fri Apr 11, 2014 8:56 pm

Dreide

I left the splicer running this morning when I went to work and returned home to find the g-code had created but it took nearly 6 hours. I forgot to save the code but the print time was far too long for such a small object.

This is the content of the slic3r.ini

bottom_solid_layers = 3
brim_width = 0
complete_objects = 0
extruder_clearance_height = 20
extruder_clearance_radius = 20
fill_density = 0.1
fill_pattern = honeycomb
infill_speed = 60
layer_height = .1
perimeter_speed = 30
perimeters = 3
raft_layers = 0
support_material = 0
support_material_spacing = 2.5
top_solid_layers = 3
travel_speed = 130
bed_size = 200,200
end_gcode = M104 S0 ; turn off temperature\nG28 X0 ; home X axis\nM84 ; disable motors
gcode_flavor = reprap
nozzle_diameter = 0.35
print_center = 100,100
retract_length = 1
retract_lift = 0
start_gcode = G28 ; home all axes\nG1 Z5 F5000 ; lift nozzle
z_offset = 0
bed_temperature = 0
extrusion_multiplier = 1,1
filament_diameter = 1.75,1.75
first_layer_bed_temperature = 55
first_layer_temperature = 200,200
temperature = 200,200

Hope this helps

Dreide
Posts: 176
Joined: Sun Sep 29, 2013 12:32 am
Location: Lausanne, Switzerland

Post by Dreide » Fri Apr 11, 2014 10:51 pm

Okay, forget about the ini. I was able to reproduce your problem with my settings but I don't know why slic3r has such a big problem with this model. Other programs, like KISSlicer and netfabb, complain about the model though, although KISSlicer slices it without problems, and so does SFACT. Anyway, I repaired the model with netfabb which, as usual, leaves some small marks. Although Repetier-Host indicates some intersecting triangles now, slic3r slices it within a few seconds. Nevertheless, maybe you should try fixing the model in your design software already.
BTW, I flipped the model upside down so it can be printed without support.
Attachments
Rudder 96th (netfabb'd).stl
(71.18 KiB) Downloaded 38 times

Studiojohn
Posts: 12
Joined: Fri Mar 14, 2014 7:48 pm

Post by Studiojohn » Sat Apr 12, 2014 7:18 am

Dreide

Thanks for the file. I will print this out later today and let you know the result. Since you were able to recreate the problem, as you rightly point out, it might be caused by the software that creates the stl in the first place. (Geomagic Design Elements). I must admit I am struggling to understand the options that are available when exporting the stl file. There are 3 main parameters that can be adjusted but the help for them is virtually non existent or at least not in everyday language. Many thanks for your help.

Post Reply