Rotary bouton (LCD Pannel) click has no effect [Solved]

Discussions about firmware/slicing software, tweaks and settings
Post Reply
Posts: 6
Joined: Tue Dec 17, 2013 1:43 am

Rotary bouton (LCD Pannel) click has no effect [Solved]

Post by Pitoun » Fri Apr 04, 2014 8:21 am

I use Felix 3.0 dual with LCD control panel and firmware V0.91 for dual extruder.
When I insert an SD card, I well see my gcode file, but there is no way to do any action with push/click on rotary button.

When using rotary LDC button I can move between menus but nothing happens when I push/click on this button.

Short ribbon cable is well connected. If I revert short ribbon cable and rotate the button, sub menus are appearing.
So I guess that hardware click function of the rotary button is (broken) doing no contacts when pushed.

What solution do you suggest?
Last edited by Pitoun on Mon Apr 28, 2014 11:03 am, edited 1 time in total.

Posts: 4
Joined: Tue Apr 15, 2014 5:34 pm

Post by structur3d » Thu Apr 24, 2014 5:22 pm

I am having the exact same issue, any solutions yet?

Posts: 17
Joined: Tue Apr 08, 2014 10:50 pm
Location: Australia

Post by GGY » Fri Apr 25, 2014 12:06 pm

Hi Felixers,
Yes I first had the same problem with the rotary/push button.
I found that the supplied (printed) knob did not grip the rotary... axle properly.
This caused the knob to rest on the display housing and not correctly depress the button press action. First I just added a bit of plastic inside the knob hole to raise the button... this did not work to my satisfaction. Then I just bought a commercial pot knob with screw/clamping to the axle, raised the knob 3mm of the display housing and tightened. Now I can feel a real click when the knob is depressed and have not had any issues any more.
Hope this will help guys,
Cheers George

Posts: 6
Joined: Tue Dec 17, 2013 1:43 am

Post by Pitoun » Mon Apr 28, 2014 11:03 am

I worte to support and they sent me a new rotary bouton. Now I can reach submenus.
Thank you support. Case closed

Post Reply