second extruder reverse direction

Discussions about firmware/slicing software, tweaks and settings
Post Reply
seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

second extruder reverse direction

Post by seaton » Mon Mar 03, 2014 2:37 pm

I've just added a second extruder to my felix and installed the current dual extruder firmware as supported by felix from their site and found that the second extruder runs in reverse to what it should be. All wiring is exactly as the other steppers.

so I changed the following in the configuration.h

#define EXT1_INVERSE 1
to
#define EXT1_INVERSE 0


Extruder 0 was already inverse
#define EXT0_INVERSE 0

Now all is working as it should.

Regards,

Stephen...
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

Kjetilei
Posts: 334
Joined: Fri Mar 16, 2012 8:26 pm
Location: Stavanger, Norway

Post by Kjetilei » Tue Mar 04, 2014 12:16 am

Or if you are lazy; rotate the wiring 180-degrees :) (At least on the old RAMPs board.)

seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

Post by seaton » Tue Mar 04, 2014 3:55 am

Kjetilei wrote:Or if you are lazy; rotate the wiring 180-degrees :) (At least on the old RAMPs board.)
Was going to do that, but for the sake of keeping all the wiring the same I decided to do it in the firmware. :)
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

Kjetilei
Posts: 334
Joined: Fri Mar 16, 2012 8:26 pm
Location: Stavanger, Norway

Post by Kjetilei » Tue Mar 04, 2014 8:43 pm

A firmware update is definitely the proper way of doing it :)

scp
Posts: 19
Joined: Mon Dec 30, 2013 1:02 am

Post by scp » Tue Mar 04, 2014 11:51 pm

This is strange; I'm using a new Felix 3.0 board and the Dual-Firmware with the original setting

Code: Select all

#define EXT1_INVERSE 1
and the wiring is as it should be. It worked out of the box. Maybe there is a difference in the wiring of the PCB between the revisions.

seaton
Posts: 291
Joined: Tue May 14, 2013 9:04 am
Location: Bunbury, Western Australia
Contact:

Post by seaton » Wed Mar 05, 2014 2:07 am

Thats what I thought initially as well and is more than likely the case as my wiring is identical on all stepper ports.

It must be on the latest boards where the wiring is incorrect as it seems strange to have to invert one port and not the other
Stephen...

Felix 2.0 -> Felix 3.0 dual
Simplify3D Slicer, Kisslicer
Have you added your Felix to the Map? http://goo.gl/maps/HajnZ

http://blog.strobotics.com.au

Post Reply