problems update firmware

Discussions about firmware/slicing software, tweaks and settings
Post Reply
gido
Posts: 2
Joined: Thu Nov 12, 2015 7:44 am

problems update firmware

Post by gido » Thu Nov 12, 2015 8:05 am

Hello community, maybe someone can help me. I bought a 3.1 DIY dual head system and build it. Now i try to update the firmware. After i push the upload button in repetier i get these message:
exit status 1
pasting "/* PINB.3, 22, MISO*/" and "_DDR" does not give a valid preprocessing token

Have someone the same problem or a way how to solve the problem.

best wishes gido

gido
Posts: 2
Joined: Thu Nov 12, 2015 7:44 am

Post by gido » Fri Nov 13, 2015 10:49 am

hello, for anyone who have the same problem. The Arduiono Version 1.6.6 was the problem. It only works with 1.6.5.

agentmulder
Posts: 49
Joined: Sat May 10, 2014 2:54 am

Post by agentmulder » Sat Nov 21, 2015 11:11 pm

Discovered this issue today.

Thanks for the update.

User avatar
janwijbrand
Posts: 37
Joined: Thu Dec 24, 2015 4:22 pm

Post by janwijbrand » Sun Jan 03, 2016 7:20 pm

Let me confirm I was able to update the Felix 3.1's firmware using Arduino IDE 1.6.5 on OS X.

The user manual for the 3.x is fairly sparse on information regarding updating firmware from OS X; I used the information in the screenshots in the Windows-section of the manual to find the correct settings:

* Board: "Arduino/Genuino Mega or Mega 2560"
* Processor: "ATmega2560 (Mega 2560)"
* Port: "/dev/cu.usbserial-A9027EDA"
Felix 3.1 single extruder, soon to be Tec 4 dual

Post Reply