Page 1 of 1

Can't upload any firmware

Posted: Fri Dec 05, 2014 10:57 am
by dparizek
Hello,

i am new to Felix 3d printers, I've bought used piece of FELIX 2.0, calibrated axis and switched to 4th generation of hot end. The last step I did was firmware upgrade. Since then I can not use my printer at all. When I try to connect to printer (same serial port as before, same baudrate), it shows in the log: "No start signal detected - forcing start". But nothing works at all.

I tried to downgrade to the previous version of firmware, but the arduino compiles all the files and then shows "uploading" for about 10 - 20min. Then it shows communication timeout.

I googled a lot and found that it may be caused by corrupted bootloader, so I switched to programmer->arduino as ISP and then "tools->burn bootloader", however this step ends on "stk500_getsync(): not in sync resp=0x00" error. I am totally lost at this point and have no other idea what can I try. The selected motherboard is Arduino Mega 2560.

I think the best point where to start is verify that the motherboard communicates with computer via the serial port (USB, in my case COM4). However I am not sure how to test it or how to make my printer work again.

I appreciate any help or advice and I am willing to provide any information you need.

The last thing to mention is that I am not a native speaker, so I am sorry for the english. Thank you.

Re: Can't upload any firmware

Posted: Tue Dec 16, 2014 4:43 pm
by guidoforrier
same problem here : time out , programmer not responding after upgrading to arduino 1.06 and rep.firmware 0.92 .

Re: Can't upload any firmware

Posted: Wed Dec 17, 2014 8:17 pm
by guidoforrier
about the arduino mega 2560 i read :
When the Mega2560 is connected to either a computer running Mac OS X or Linux, it resets each time a connection is made to it from software (via USB). For the following half-second or so, the bootloader is running on the Mega2560. While it is programmed to ignore malformed data (i.e. anything besides an upload of new code), it will intercept the first few bytes of data sent to the board after a connection is opened. If a sketch running on the board receives one-time configuration or other data when it first starts, make sure that the software with which it communicates waits a second after opening the connection and before sending this data."
has this to do with the time out ?
how can i cure this problem ?

Re: Can't upload any firmware

Posted: Wed Dec 17, 2014 10:39 pm
by guidoforrier
now i have :
failed miserably to execute command 8X11
failed to leave programming mode
i can upload nothing

Re: Can't upload any firmware

Posted: Thu Dec 18, 2014 4:14 pm
by guidoforrier
i started from zero : all software , firmware etc... deleted
using this guide the printer works , except nox that the extruder does not retract or extrudes : motor not working .....
in dutch :
http://www.fablab.ugent.be/data/uploads ... _0_v10.pdf
guido

Re: Can't upload any firmware

Posted: Thu Dec 18, 2014 5:30 pm
by guidoforrier
all ok , so far ..........
guido

Re: Can't upload any firmware

Posted: Fri Dec 26, 2014 10:52 pm
by fekr58
I have the same problem with the extruder. Everything works fine, however the extruder motor does not move.
I tried the FW 0.92 V2.0 as well as the FW 0.92 V3.0. Nothing changed. Also the Marlin FW RC3 Felix 1_5 shows the same effect. The Motor connections are o.k. The motor itself is also o.k. (checked on z- axis output).

Seems that guidpo could fix the problem? Any hint? Re-install the Bootloader?

Re: Can't upload any firmware

Posted: Thu Jun 11, 2015 8:15 am
by Deluka
While i was uploading the latest firmware i got a error
stk500v2_getsync(): timeout communicating with programmer
Solved it by using a arduino Uno and the information found
here http://www.gammon.com.au/forum/?id=11635
After this i can upload the firmware the normal way