September 2014 Firmware Update

Discussions about firmware/slicing software, tweaks and settings
Post Reply
kerog
Posts: 117
Joined: Mon Jun 09, 2014 1:54 am

September 2014 Firmware Update

Post by kerog » Fri Sep 26, 2014 10:36 pm

Hi,

I downloaded and installed the new firmware on my Mac. Now I'm getting messages on Rep-Host saying that the following commands in the gcode it is producing are "Unknown":

M113
M108
M101
M103

Anyone know what these commands are? Anyone having the same problem?

-Keith

Bitpower
Posts: 10
Joined: Mon Dec 16, 2013 11:05 pm

Post by Bitpower » Sun Sep 28, 2014 3:22 pm


kerog
Posts: 117
Joined: Mon Jun 09, 2014 1:54 am

Post by kerog » Sun Sep 28, 2014 6:52 pm

Thanks, but it doesn't answer the question of why those errors are starting up with the new firmware. Even if they are deprecated, shouldn't the new firmware still recognize them? If they aren't being recognized, will that screw up a print? Shouldn't SFACT be generating up-to-date g-code?

Raises a lot of questions. I'd like to go to the new firmware because I think the safety cutoffs are probably very important in preventing damage to the hot end when a thermistor fails, but I want to be sure I'm not going to break something else.

scp
Posts: 19
Joined: Mon Dec 30, 2013 1:02 am

Post by scp » Tue Oct 14, 2014 11:08 pm

Kerog,

none of the commands you have mentioned was supported by the old Repetier firmware 0.91. Maybe you simply have not noticed it.

IMHO there was not ANY Gcode command removed with the new version 0.92. Just have a look into Repetier.ino or the source Commands.cpp.

Paul

Post Reply