Felix Builder + gcode

Post Reply
smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Re: Felix Builder + gcode

Post by smuseus » Wed Sep 21, 2016 11:15 pm

1. Where would I find instructions on how to update the firmware drivers?

Felix Builder connects, however the printer takes no commands from UI.. I'm trying to control it manually...

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Wed Sep 21, 2016 11:23 pm

Here's what the log says, there seems to be no response from the UI when I'm pressing it, no send attempted..

Code: Select all

00:20:02.109 send : N5 M105 
00:20:04.246 send : N6 M105 
00:20:06.616 send : N7 M105 
00:20:09.812 send : N8 M105 
00:20:11.126 send : N9 M105 
00:20:14.088 send : N10 M105 
00:20:14.226 recv : áq)lq€_r6ìMpˆôì@e˜4~r°NÔàA.:ìMrY6 é> È7´ì<	BahpQþ	BaM|„,]:„	Bahr<ø	Bamø„àmhr„Mry¯]C&yM|Hì}qšùXš:ø	Bam|„àmm\„&yQ¯“›ì\l+–û6Ì	Bamøì,.:	àmhrìàmmø„»mu|ìàmhr	àmmøþ)Bam|„	Bam|„MrY6 é>paM€Ù+–û6Ì	BaM|	»mu|Ì,.:ì,.+:„	Bam|	àmmø„,]:ì,]:	,w:ì	BaM|S,]:	àmmø„&yQ6 ù>p\}šùXš:ø	Bahr	àmmø„,.:„àmmø„,w:		Bahr<ø,»:„,»+:„,.:ì	Bamøì	Bamø„)Bam\S³M~6 ù>ðHú}šù]Aÿ,]:ìàmm|S,.:	,.+>S	Bahr<ø	Bahr<ø,]:ì,]+:		Bamø„,]:	,wmq|S	BamøSMrY6 éÔàHú}šùXš:	FaHr<øàmmø„,]:ì	Bam\S	BaM|		Bahr<øwmqø	,]:„	Bahr<ø,.:ì	Bahò„	Bahr<øMrY°NÔàHÌõ}+–:ì8›
00:20:17.630 send : N11 M105 
00:20:19.935 send : N12 M105 
00:20:22.319 send : N13 M105 
00:20:24.899 send : N14 M105 
00:20:27.785 send : N15 M105 
00:20:29.649 send : N16 M105 
00:20:32.943 send : N17 M105 
00:20:34.199 send : N18 M105 
00:20:37.705 send : N19 M105 
00:20:39.845 send : N20 M105 
00:20:42.744 send : N21 M105 
00:20:42.861 recv : Ô™XRÔà\}šùXM"þ	BaHr<ø	Bam|S	Bahr	)Bam|S	BaM|	àmÚ:pQþ	Bam|„,w:ì,]:ì	Bahr<ø	BahðQþ,.:	,]:		Bamø„,w:ì“b~6 ùÔàHÌõ}š|mì8nññyž~"|ì]qMùXš:øàmM|	àïhr<øàmm\„,.:ì	Bahr<ø	Bahr<ø»mu\S	Bahr<ø	Bamø„,]+:ì	Bahr		Bamøì³Mü6 é|x\lßXØùmÌàmm|„,.:	àmmø„,]:ìàmú:p„àmM|	,.+:	,»:		BamøSàmM|	,.:„,]:„&yQ»O&yM|Hõ}šùm„,»:Ì,Wûm|Sàï0hð(þ,]:„,]:		Bam|S	Bahr<ø,]:ì,]:ÌàmmøS	Bahðì,]:	³M~6 ùÔàL" l”XØÙm„àmÚ|		BaÚ|SàmÚ\S	Bamø)	Bam\S	Bahr	àmmø„,»mq|ì	Bahrþ,]ºì	FaÚ\S	BaÚ\S³Mü6 ùÔà\ÜßX}6ì	Bam|S	Bahr<ø	Bam\	,.:ìàmmøì,]:„)Âa0Hr„wÛM|Ì	Bamøì,]:	,.:ì	Bahr	“NuñyŽü>pHì]q+–û6Ì,]:		Bahr<øàmm\S,]:Ì,]:„àmM|		Bam|S	Bamøìw:ì	Bahr<ø)Âamø(þ,.:ì&yQŸ6 é>pHõ}šùXš:ø,.:ì	Bam|		Bahr<øàmm|	àmhr<ø,]:	àmÚ|SàmmøìàmÚøì	Bamøì,wmqø	,]:	“nqñyŽ~"øHõ}Mù6Ìàmhr„àmmø„àmmøì	Bam|	,w:„,.:ìàmM|	,.:„,.:„,]:	àmmø„àmmø„&yQŸ°N>pHÌõúoP»m" üNuñyŽü>pHìõ}šùÿ	Bam\SàmÚøì,.:	,]:	àím|S,.:„àmÚ|S	Bahr<ø	Bahr„,]:„,wmq\Sàmm\S“Nqñyž~"\ú}šùxM"üàmmøìàmm|		Bahr<ø,w:„,.:ì	Baúøì	Bahr<ø	BaÚø	]:„,]:„,wmq|„,w:ì³›
00:20:45.856 send : N22 M105 
00:20:47.850 send : N23 M105 
00:20:50.609 send : N24 M105 
00:20:52.717 send : N25 M105 
00:20:55.178 send : N26 M105 
00:20:58.283 send : N27 M105 
00:21:00.801 send : N28 M105

User avatar
gfeliksdal
Site Admin
Posts: 400
Joined: Sat Feb 25, 2012 10:40 pm
Location: Netherlands
Contact:

Post by gfeliksdal » Wed Sep 21, 2016 11:34 pm

So your computer is able to find the printer, so it is not a driver issue. so it seems.

Please install the firmware for the 3.1 single head onto your printer (the control board is the same). I think felixbuilder might not understand the responses from that firmware.

Download this firmware
http://www.felixprinters.com/downloads/ ... are_source
Install arduino 1.6.5...newer versions won't work.

Then follow the instructions here from chapter 4.3.1, to install the firmware
http://www.felixprinters.com/downloads/ ... _0_V10.pdf

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 8:51 am

I installed the new drivers, but nothing changed, still unresponsive.

With the old version of Felix Builder it would connect and I would be able to control it, but only for a couple of instructions before it would drop out and I would need to reconnect to make it work again.

The log doesn't even seem to send commands when I press the UI, and the recv are still all scrambled.

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 9:35 am

I can confirm that the printer is working, by uploading to an SD card I'm able to printer just fine.

However, from the computer, neither Repetier, nor Felix Builder is able to communicate with the printer.

Repetier crashes the moment I connect the printer, Felix Builder does not repsond and crashes very often.

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 4:06 pm

case remains unresolved, any assistance please?

User avatar
gfeliksdal
Site Admin
Posts: 400
Joined: Sat Feb 25, 2012 10:40 pm
Location: Netherlands
Contact:

Post by gfeliksdal » Thu Sep 22, 2016 10:00 pm

Strange that both programs get instable. What kind of computer do you use? Also do you connect the computer via a USB-hub? If so, please try to connect without a hub.

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 10:14 pm

it's a Retina, 15-inch, late 2013. No hub, USB directly in the USB port..

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 10:20 pm

I managed just fine to connect via arduino and upload the firmeware, via same cable... so problem resides somewhere else.

smuseus
Posts: 20
Joined: Mon Mar 24, 2014 3:43 pm

Post by smuseus » Thu Sep 22, 2016 10:33 pm

Diagnostics.. I press 'Connect', the printer fan stops, waits a second, then starts again. In the Log windows there's a steady stream of send: M105, which I understand to be a read temperature g-code calls. the recv message however consists of a bunch of jabled characters... I try to manually send g-code commands, however these do not appear in the log window and causes no reaction on the side of the printer... The UI says that I'm connected, buttons are working, however they to trigger no response on the side of the printer or in the log window.

Current printer is set to Felix dual extruder, with a Baudrate of 115200.. as far as I can tell, that's all the settings I got to choose from.

Post Reply