Felix wont install

General discussions regarding hardware
Post Reply
instasquid
Posts: 22
Joined: Tue Oct 29, 2013 3:56 am

Felix wont install

Post by instasquid » Mon Aug 01, 2016 12:40 am

My Felix 3 was working fine, but after relocating it in my workshop it is no longer recognised when plugged into my Windows 7 box.

I have uninstalled and reinstalled the drivers and software, I've tried a bunch of different usb cables and ports on my pc but nothing makes it recognisable/install.

Any ideas how I can get it to work?

matthijs
Posts: 7
Joined: Mon May 02, 2016 2:36 pm

Post by matthijs » Mon Aug 01, 2016 3:22 pm

Hello Instasquid,

Is this the same windows 7 box you used before?
Does your printer have a display? If so, does it show the usual info when you power it on?
Do you see any device show up in the windows Device manager when you plug in and turn on the printer? The Felix 3 should show up as a USB serial port.
If nothing changes in the device manager, there must be something wrong with the main board. Can you check if it is still mounted well inside the plastic casing, and that it does not touch the metal case of the power supply?
If you see an unknown device appear (with yellow exclamation mark or a question mark), something is wrong with the driver files. Try completely uninstalling the driver files from within the "Programs and Features" menu from the windows control panel. Then reinstall the latest Repetier-Host from our site, it has an option to install the latest driver files.

Post Reply