Website / Forum rehaul

Let us know what you think of our website

Moderator: speedake95

Post Reply
JTa
Posts: 36
Joined: Sat Feb 02, 2013 6:02 pm
Location: Finland

Website / Forum rehaul

Post by JTa » Thu May 14, 2015 12:59 pm

Once again the site gets revamped?

Some observations:
1. Login will not work before you remove old cookies for it.
2. Some images on the site are HUGE. With slow connections (f.e. with mobile phone) it takes a while for the pages to load. Some optimization would be a good idea.
3. Color theme is a bit funny. I'm not color blind but it's really hard to read orange (?) text on white background. Might be my old laptop and it's backlight getting dimmer but I don't have such problems in other sites. Such big contrasts between colors makes a website feel restless.
4. Some forum text items seem to be untranslated or something. I don't think it should read "RETURN_TO_SEARCH_ADV" on the search results page?

Looks like the marketing/webdesigner people have got all their ideas through. Usually it's not the best way to do things in the internet world from what I have learned after working in that industry for past 15 years before bailing out. Web designers have their macs with big screens and fat internet pipes to work with which results in sites that are not so user friendly to the rest of the world with slow internet connections and small screens. :)

User avatar
gfeliksdal
Site Admin
Posts: 400
Joined: Sat Feb 25, 2012 10:40 pm
Location: Netherlands
Contact:

Post by gfeliksdal » Thu May 14, 2015 2:02 pm

Hi JTA,

Thanks for the feedback. Unfortunately the transition form the old website to the new didn't go as smooth as expected. The web developer is working on it.

He will fix all remaining bugs like missing links and migrate all data from the old forum to this one asap.

Kind regards,

Guillaume

Hugues
Posts: 270
Joined: Thu Apr 04, 2013 5:36 pm

Post by Hugues » Fri May 15, 2015 8:15 pm

JTa wrote:...
1. Login will not work before you remove old cookies for it.
....
Thanks for the tip, this solved my login problem.
Hugues
Regards from Switzerland

hoolito
Posts: 95
Joined: Wed Feb 27, 2013 7:15 pm

Post by hoolito » Sun Jul 26, 2015 8:07 pm

Idem ditto here about the cookies.... Thank you for posting that.
I was getting :x
Felix 2.0

JTa
Posts: 36
Joined: Sat Feb 02, 2013 6:02 pm
Location: Finland

Post by JTa » Thu Sep 10, 2015 6:05 pm

Some fixes seem to be done. But still there are bugs in
the css. For example quite a few images are not shown in the forum. Seems like -icon suffixed styles are missing or half-done. F.e. pm-icon, report-icon, quote-icon, etc.

And the font size in the message body should be bigger as not all of us have a magnifier glass available all the time. At least the font colors are better and can be seen by us color-challenged people too. :D

Also the padding in the ".nav-primary" links is one pixel (!) too big and that makes the navigation bar to wrap on any width screen.

Give the web designer a smaller display already! And make him/her to actually test his stuff before release. Thank you.

Post Reply